Back to overview
Degraded

Incident affecting file upload and access via R2 (Cloudflare)

Nov 01 at 10:19pm GMT-4
Affected services
Wiki Cluster #1
Other Wikis Cluster
Third-party services

Resolved
Nov 03 at 06:10pm GMT-4

Cleaned up the Varnish server to mitigate potential cache issues with images.

Updated
Nov 03 at 06:06pm GMT-4

The problem with the connection to Cloudflare's R2 has been solved. It was an error related to the subscription not being validated correctly.

Files can now be uploaded correctly, and files that were shown as non-existent or broken should now be displayed again.

Updated
Nov 02 at 05:30pm GMT-4

The wikis are still active and are flagged as active

Updated
Nov 01 at 10:41pm GMT-4

🚨✅ - These files remain fully intact and their data integrity is not compromised. However, due to the current connectivity issue between our infrastructure and Cloudflare R2, they are temporarily inaccessible. Once the connection is fully restored, all affected files will become available again without any loss or corruption of data.

Updated
Nov 01 at 10:35pm GMT-4

Some files may respond with 403 Forbidden in the meantime, especially on wikis such as Polandball FR Wiki that contain recent files uploaded in the last 2 weeks.

Created
Nov 01 at 10:19pm GMT-4

A technical issue has been detected impacting file storage and delivery through Cloudflare’s R2 service, which handles image and media hosting for the wikis. Some files may currently fail to display or return errors when accessed or uploaded, showing messages such as:

“Could not write file ‘mwstore://AmazonS3/local-public/f/f3/Test.jpeg’”

This issue appears to be related to a temporary disruption in the connection between MediaWiki and the R2 storage bucket. I am investigating and working to reestablish stable communication with R2 to ensure full restoration and data integrity.

Spanish (ES):
Se ha detectado un problema que afecta la disponibilidad y carga de archivos alojados en el servicio R2 de Cloudflare, el cual gestiona el almacenamiento de imágenes y archivos multimedia utilizados por los wikis. Actualmente, algunos archivos pueden no visualizarse correctamente o arrojar errores al intentar acceder o subir nuevos contenidos, mostrando mensajes como:

“No se pudo escribir el archivo ‘mwstore://AmazonS3/local-public/f/f3/Test.jpeg’”

Este inconveniente podría deberse a una interrupción temporal en la conexión entre MediaWiki y el bucket de R2. Me encuentro investigando y aplicando medidas para restablecer la comunicación con el almacenamiento, asegurando la integridad y disponibilidad de los archivos afectados.